Trouble with IPv6 and VRFs: Cannot assign requested address

Ralf Jung post at
Tue Jan 1 15:26:36 CET 2019


>> I was beginning to suspect the same.
>> What would be a good place for the bug report?  Some kernel teams seem to prefer
>> Bugzilla and others their mailing lists, and I have a very mixed track record
>> for getting any reaction at all from kernel bug reports (as in, about half my
>> reports never got any reply).
> I would suggest linux-netdev mailing list and Cc to David Ahern <dsahern at>.

I'll try that, thanks.

>>> You could try modified configurations (e.g. multihop instead of direct,
>>> real ethernet interface (or dummy interface) instead of tun interface)
>>> to see if the issue is related to some of these variants.
>> Unfortunately I only control one side of the BGP session here, and I don't have
>> any BGP experience so I wouldn't even know how to go about doing such experiments.
> For this you do not need the other side - the error happens immediately
> when BIRD tries to initiate the connection, so it does not matter if
> anyone listens on the other side.

Oh, of course.
I tried a dummy device, no change in behavior.  I tried removing the "direct;",
no change in behavior.

Unfortunately this machine only has one "real" interface (and it's a VPS so even
that is not really real), so I'll probably just lock myself out if I try to put
that into a VRF.

Kind regards,

More information about the Bird-users mailing list