Patch for renaming sk_new()

Wes Hardaker opensource at
Mon Jun 18 17:06:34 CEST 2012

Ondrej Zajicek <santiago at> writes:

Sorry for the delay (I went on vacation shortly after sending that last

> Hmm, using such generic prefix like sk_ in public library like OpenSSL
> is definitelyt not a good idea on their side, but i guess we have to
> make a change to be able to link to it.

Well, I don't think they'd accept a change to their (long) published
API, so I didn't submit one to them.

> I would prefer less intrusive patch like the attached one (keeping
> sk_new() name using macro). Try it and let us know whether it is OK
> for your purpose (you have to just
> #undef sk_new before including OpenSSL in files that use OpenSSL).

You didn't attach the patch though.

A macro would certainly be ok, until you ran into the case where you
needed both the openssl function and the macro in the same file, but
that's unlikely.  Personally, I think it'd be better to rename it
entirely to something new like my patch did as it seems cleaner and less
confusing (especially when debugging).  There aren't that many files to
change.  But the choice, of course, is yours.

Wes Hardaker                                     
My Pictures:
My Thoughts:

More information about the Bird-users mailing list