BGP flapping while peering with Juniper - Hold timer expired error

Ondrej Zajicek santiago at
Thu Sep 5 13:11:15 CEST 2013

On Thu, Sep 05, 2013 at 05:41:00PM +0800, Jimmy Halim wrote:
> Hi Santiago,
> BIRD running on Centos. The 2nd working session also use the same MD5
> password and same hardware. The funny part is we have just fixed the issue
> by removing the MD5 password. We then tried a different MD5 password but
> the session flaps again.
> The funny part, when the BGP is established during the flap, I don't get
> any routes from the neighbour. But the neighbour claims that they received
> all prefixes that are advertised by us. Is there any other aspect that
> might cause this?

I guess that initial packets that established session worked, then BIRD
side ignored next received packets. It sent its prefixes and either TCP-ACK
packets were not ignored, or the number of exported prefixes were small
enough that it does not matter.

Elen sila lumenn' omentielvo

Ondrej 'SanTiago' Zajicek (email: santiago at
OpenPGP encrypted e-mails preferred (KeyID 0x11DEADC3,
"To err is human -- to blame it on a computer is even more so."
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <>

More information about the Bird-users mailing list