Netlink: Cannot allocate memory (solved)

Ondrej Zajicek santiago at
Mon Dec 13 11:37:12 CET 2010

On Sat, Dec 11, 2010 at 10:09:25PM +0100, Petr Šťastný wrote:
>    All right. I solved this problem after hours of googling.
>    It is caused by the limit of enteries in IPv6 kernel routing table, which
>    is defined in /proc/sys/net/ipv6/route/max_size and is 4096 by default.
>    But we have more than 4096 IPv6 routes, so it crashed when adding 4097th
>    entry into kernel table. But it also took down OSPF communication.

Thanks for a note. I didn't know about this limit.

>    Maybe bird should check this limit and tell more interesting error
>    message? Thanks.

It would be probably better to put that to some doc/FAQ.

Elen sila lumenn' omentielvo

Ondrej 'SanTiago' Zajicek (email: santiago at
OpenPGP encrypted e-mails preferred (KeyID 0x11DEADC3,
"To err is human -- to blame it on a computer is even more so."
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <>

More information about the Bird-users mailing list