Status of bird project

Zharovtsev, Anton warm at
Mon Apr 19 03:49:42 CEST 2004


Realms described in iproute2 documentation
It can be usefull with iptables or ip rule or some thing else ... For
example I use realms to limit my city traffic and to find IP in a blocks
of city nets:

root at warm:~# ip ro sh realm tpu via dev eth0  proto bird realm tpu via dev eth0  proto bird realm tpu via dev eth0  proto bird realm tpu via dev eth0  proto bird realm tpu via dev eth0  proto bird realm tpu


root at warm:~# ip ro get via dev eth0  src realm StackNew
    cache  mtu 1500 advmss 1460

I have patch writen by my friend but he does not support it any more ...

Bird was not configured becouse I had wrong installation of 2.6.5 kernel
headers, sorry :-).
Bird was not compiled becouse I had upgradedt to very new bison
(1.8...), after downgrade all is fun.
I have not tried to "autoconf" bird with a new bison yet

Last time I have compiled bird saccessafuly with the origin ./configure
2.6.5 kernel and bison 1.35(old bison in slackware)

-----Original Message-----
From: Martin Mares [mailto:mj at] 
Sent: Friday, April 16, 2004 6:24 PM
To: Zharovtsev, Anton
Cc: bird-users at
Subject: Re: Status of bird project


> 1. Is a project alive ? Gated is dead, zebra is unstable (IMHO
> - I don't like zebra), quagga is strange fork from zebra. Is only bird

> for linux and its several routing tables support.

BIRD is alive, but very, very slowly, since all people of the original
BIRD team are currently working on other things which have turned out to
be very successful time eaters.

> 2. Are the any plans to include realms support ? (I have a patch from 
> my friend, but friend is lazy and he has stoped developing this patch)

Well, what type of realms have you exactly in mind?

> 3. Bird does not configure whith a linux-2.6.x kernel headers (I try 
> 2.6.4 and 2.6.5 but it seems that all 2.6.x hase the same result)
> checking protocols... ok
> checking for linux/rtnetlink.h... no
> configure: error: Appropriate version of Linux kernel headers not 
> found.
> How to fix this ? linux/rtnetlink.h is in its place ...

This should be pretty easy to fix. I'll look at it soon (it's a bit
problematic now as I've moved to Berlin for 6 weeks and the things
haven't settled here yet).

> I have tried to generate a new configure, but I could not. Usualy some

> projects have a whitch deals whith auto-tools and other 
> prepearing things ...

BIRD doesn't use automake nor any other fancy stuff, so running
"autoconf" should be enough.

> 4. After full upgrade my Slackware to Slackware-current bird does not 
> compile even whith 2.4.25 kernel headers
> m4 -P ../../conf/gen_parser.m4 ../../conf/confbase.Y 
> ../../sysdep/unix/config.Y ../../sysdep/unix/krt.Y 
> ../../sysdep/linux/netlink/netlink.Y  ../../nest/config.Y
../../filter/config.Y ../../proto/bgp/config.Y ../../proto/ospf/config.Y
../../proto/pipe/config.Y ../../proto/rip/config.Y
../../proto/static/config.Y >cf-parse.y bison -bcf-parse -dv -pcf_
> cf-parse.y:1407.2: syntax error, unexpected "|"
> cf-parse.y:1435.3: syntax error, unexpected "|"
> make[3]: *** [] ?????? 1
> I think this is new auto-tool or some thing else (I am not a 
> programmer :-))

Can you send me your configure options?

Did you use the original configure script or the one you tried to

				Have a nice fortnight
Martin `MJ' Mares   <mj at>
Faculty of Math and Physics, Charles University, Prague, Czech Rep.,
"while (*p++ = *q++);"   -- Dennis M. Ritchie

More information about the Bird-users mailing list