Configuration Problem : announce default route via ospf

Raphael Mazelier raph at futomaki.net
Sun Jan 13 17:07:46 CET 2013



Hello list,

I'm a new user of bird. I'm using quagga or openospdf in production for 
time (also cisco and junos).
Bird have an excellent reputation and a small footprint.
I m trying to replace my old quagga on embedded box (running openwrt) 
with bird.
The configuration look very flexible but I'm facing with a problem. What 
I try to make is announcing a default route in ospf,
and also set some specific metric. I'm lost with that.

The quagga/ospfd relevant part of configuration I try to make :

- snip -
interface lo2
  ip ospf cost 100

router ospf
  ospf router-id 0.0.0.9
  redistribute connected route-map connected_to_ospf
  passive-interface lo0
  passive-interface lo1
  passive-interface lo2
  network 192.168.0.0/24 area 0.0.0.5
  network 192.168.10.9/32 area 0.0.0.5
  network 192.168.10.53/32 area 0.0.0.5
  default-information originate metric 100
!
access-list access permit 127.0.0.1/32
access-list access deny any
!
route-map connected_to_ospf deny 10
  match interface mpe0
!
route-map connected_to_ospf deny 15
  match interface vlan44
!
route-map connected_to_ospf permit 20
  match interface lo2
  set metric 100
  set metric-type type-1
- /snip -

I gave up with a config like this :

- snip -
router id 0.0.0.9;

protocol device {
         scan time 10;
}

filter export_OSPF {
     if ( net = 0.0.0.0/0 ) then {
         print "default net accepted:", net;
         ospf_metric1 = 100;
         accept;
     }
     accept
}

protocol kernel {
         debug all;
         learn;
         scan time 2;
         import all;
         export all;
}

protocol ospf {
         debug all;
         import all;
         export filter export_OSPF;

         area 0.0.0.5 {
                 stubnet 192.168.10.53/32 {
                         cost 100;
                 };
                 interface "lo1" {
                         stub;
                 };
                 interface "lo2" {
                         stub;
                 };
                 interface "vr0" {
                         cost 5;
                         type broadcast;
                 };
                 interface "vr1" {
                         stub;
                         cost 200;
                 };
         };
}
- /snip -

It's not working as expected. In fact I'm trying to redistribute defautl 
kernel route into ospf. but it seems to be ignored, and the default was 
not seeen in the ospf database.

What I am missing ? Is there a better way to inject a default route like 
in quagga (default originate).


Regards,


-- 
Raphael Mazelier






More information about the Bird-users mailing list